您的位置 首页 股票知识

通达信指标公式源码 涨停板主图

通达信指标公式源码 涨停板主图

预测涨停选股私式



收撑价:LLV(LOW,19) ,COLORGREEN,LINETHICK3;
阻力价:HHV(HIGH,19),COLORBLUE, LINETHICK3;
VAR1:=EMA(CLOSE,12)-EMA(CLOSE,26);
JL01:=MA(C,3);
LJL07:=(3*C+L+O+H)6;

线:(20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF
(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL
07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,
12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)
+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))210,COLORRED;
马线:MA(牛线,5),COLORYELLOW,LINETHICK4,POINTDOT;
期待:IF(JL01<=牛线,马线,DRAWNULL),COLORRED,LINETHICK4,POINTDOT;
VAR1L:=(C>REF(C,1) AND C>REF(C,2));
VAR2L:=(REF(VAR1L,1) AND C=REF(C,2));
VAR3L:=(REF(VAR2L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR4L:=(REF(VAR3L,1) AND C=REF(C,2));
VAR5L:=(REF(VAR4L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR6L:=(REF(VAR5L,1) AND C=REF(C,2));
VAR7L:=(REF(VAR6L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR8L:=(REF(VAR7L,1) AND C=REF(C,2));
VAR9L:=(REF(VAR8L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARAL:=(REF(VAR9L,1) AND C=REF(C,2));
VARBL:=(REF(VARAL,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARCL:=(REF(VARBL,1) AND C=REF(C,2));
持股:IF(VAR1L OR VAR2L OR VAR3L OR VAR4L OR VAR5L OR VAR6L OR
VAR7L OR VAR8L OR VAR9L OR VARAL OR VARBL OR VARCL,牛
线,DRAWNULL),COLORRED,LINETHICK1;
VOL6.7 AND CLOSE8.19 AND
CLOSE<8.21));
DRAWTEXT(FILTER(续对售点>0,3),H,'危害'), COLOR00FF00;
DRAWTEXT(股海万元户>0,L,'☆逃涨'),COLORYELLOW
DRAWICON(购点>0,L,4);
DRAWTEXT(购点>0,L,'扫描神针'),COLORF00FF0;
DRAWTEXT(VARF0,L,'抄底'),COLORYELLOW;
STICKLINE(VAR2D>0,O,C,10,0), COLORYELLOW;
DRAWTEXT(VAR2D>0,L,'慷慨神针'),COLORRED;
DRAWICON(COUNT(REF(VAR4,1)<REF(VAR4,2),5)=5 AND
VAR4>REF(VAR4,1),L*0.98,5);
DRAWICON(FILTER(COUNT(VAR6<0,5)AND CROSS(VAR6,0)AND
VARF>REF(VARF,1)AND C>O,3),L,11);
DRAWICON(FILTER(REF(VAR4,1)>REF(VAR4,2)AND VAR4<REF(VAR4,1)AND
VARF>17 AND VAR1>VAR2,5),H,12);
DRAWICON(阻力价>REF(阻力价,1)AND CROSS(阻力价,VAR3)AND
C<O,H*1.02,6);
Y:=CLOSEREF(CLOSE,1)>1.07;
X:=VOL>MA(VOL,5);
A1:=Y AND X;
DRAWTEXT(A1,MA(CLOSE,5),'攻涨停'),COLORMAGENTA;
Z:=CLOSEREF(CLOSE,1)<0.93;
W:=VOL<MA(VOL,5);
A2:=Z AND W;
DRAWTEXT(A2,MA(CLOSE,5),'小口跌停'),COLORGREEN;

VARC:=(CLOSE-LLV(LOW,981))(HHV(HIGH,981)-LLV(LOW,981))*100;
VARD:=(CLOSE-LLV(LOW,393))(HHV(HIGH,393)-LLV(LOW,393))*100;
VARE:=VARC>98.5 OR VARD>98.5;
VARF:=EMA(100*(CLOSE-LLV(LOW,100))(HHV(HIGH,100)-LLV(LOW,100)),5)
4;
VAR13:=VARA=0 AND VARC=0 AND VAR6<0;
VAR14:=VARA=100 AND VARC=100;
VAR15:=VARB=0 OR VARD=0 AND VAR9<0;
VAR16:=VARB=100 AND VARD=100;
VAR17:=VAR6<0 AND VAR9<0;
VAR18:=VAR13 AND VAR15;
VAR19:=VAR14 AND VAR16;
VAR1B:=SMA(MAX(CLOSE-REF(CLOSE,1),0),49,1)SMA(ABS(CLOSE-REF(CLO
SE,1)),6,1)*100;
VAR1C:=SMA(MAX(CLOSE-REF(CLOSE,1),0),14,1)SMA(ABS(CLOSE-REF(CLO
SE,1)),14,1)*100;
VAR1D:=BARSCOUNT(CLOSE);
VAR1E:=VAR1B<20 AND VAR1C35;
VAR1F:=VAR1E AND COUNT(VAR1E,1)=1;
VAR20:=REF(CLOSE,1);
VAR21:=SMA(MAX(CLOSE-VAR20,0),34,1)SMA(ABS(CLOSE-VAR20),7,1)*100;
VAR22:=SMA(MAX(CLOSE-VAR20,0),13,1)SMA(ABS(CLOSE-VAR20),13,1)*10
0;
VAR23:=BARSCOUNT(CLOSE);
VAR24:=VAR21<20 AND VAR2235;
VAR25:=VARA=0 AND VARF<1.2 AND VAR17;
VAR27:=VAR18 AND VARF<1.2 AND VAR17;
VAR29:=SUM(HIGH-OPEN,77)SUM(OPEN-LOW,77)*100;
VAR2A:=SUM(MAX(0,HIGH-REF(CLOSE,1)),77)SUM(MAX(0,REF(CLOSE,1)-LO
W),77)*100;
VAR2B:=CROSS(VAR29,69) AND CROSS(VAR2A,80)<150;
VAR2C:=VAR24 AND VAR1F AND COUNT(VAR24,30)=1;
购点:=VAR25 AND VAR2B;
续对售点:=(VAR19 OR VARA)AND VARF>23 OR VARE
VAR2D:=VAR1F AND VAR2C AND VAR25;
股海万元户:=(CLOSEREF(CLOSE,1)>1.04 AND (CLOSE>10.8 AND
CLOSE6.86 AND CLOSE13.82 AND
CLOSE7.28 AND CLOSE12.4 AND
CLOSE22.33 AND CLOSE4.68 AND
CLOSE26.29 AND CLOSE7.65 AND
CLOSE13.4 AND CLOSE7.58 AND
CLOSE20.43 AND CLOSE19.57 AND
CLOSE6.26 AND CLOSE7.14 AND
CLOSE6.61 AND CLOSE11.9 AND

预测涨停选股私式


关于作者: 股票配资

热门文章

发表评论

电子邮件地址不会被公开。 必填项已用*标注